Installing TomTom GPS from your Mac

Discussion in 'Treo and Mac OS X' started by cmeinck, Jul 24, 2005.

  1. cmeinck

    cmeinck Administrator

    Those of you trying to install TomTom using your Mac will find this link helpful.

    TomTom Install on Mac
  2. Xof711

    Xof711 New Member


    Did you successfully installed TomTom on your Treo 650 using your Mac??
    I was contemplating this solutions versus buying a GPS Kit for my car ha!
  3. cmeinck

    cmeinck Administrator

    With that link, the install was a breeze. The biggest hurdle for me was activation -- but that's neither a Mac or PC thing. I'm guessing they've fixed that. The good thing about having GPS on your Treo is the portability. I can take it anywhere and it works. Plus, from a cost perspective, it's more affordable than dealer installed nav systems or even the TomTom Go.

    Works great.

  4. Xof711

    Xof711 New Member


    I know!! way more affordable... I am working on a set up where I could use it on my motorcycle too!
    I'll keep the forum posted on that
  5. cmeinck

    cmeinck Administrator

    Plus, there's not compromise on quality. Because the Treo 650 has such a great screen, it makes GPS affordable. I probably wouldn't invest $700 or so on a GPS system and I'd be missing out. Luckily, I've got a Treo.

    Interesting.. let us know. Post pics!

  6. pdhoang

    pdhoang New Member

    tomtom + mac + verizon treo

  7. cmeinck

    cmeinck Administrator

    I'm not sure if carrier has anything to do with compatibility?

  8. tomm

    tomm New Member

    problems installing tomtom Navigator 5 on the Mac


    I am continuously having problems installing the tomtom navigator 5 software on the Powerbook (OS 10.4.3), right after I solve one problem I run into another one. Tomtom customer support is useless - they NEVER call back. I've been waiting now for 3 days and about 10 phone calls. If the software apparently was not so good, I'd give up and demand my money back. I'm really sorry I bought it.

    I gave up on trying to install from the CD, since the tomtom conduit was not seen by Missing Sync (5.02), but after trying the tomtom 5.21 update, the conduit was installed and I was able to install the tomtom application, but got stuck again on the Maps.

    I installed the Canadian map from the map CD1 (90 mb, it took over 1 hr using the USB sync), but the Navigator on the Treo can't find any maps, even though I copied some more maps (expanded from the CAB files using Stuffit Expander) and copied them to the SD card tomtom directory using a card reader. I than installed the original Navigator from the CD again and now the Navigator still can't see the maps and gives me an option to download maps, after putting in my user and password, which of course I don't have. I don't see the option to activate the maps I have - probably since it can't see them.

    I need some advise what to install or re-install so that my maps will be recognized by the Navigator so that I can activate them.

    Last edited: Dec 9, 2005
  9. cmeinck

    cmeinck Administrator

    Let me see if I can help in some way. I wasn't able to install from my CD, but was able to install from the image on the TomTom site. I understand your frustration, but you'll be rewarded once it's set up. I'm using Missing Sync and TomTom without a problem.

    I'd suggest deleting what TomTom files you have currently on your Treo and start from scratch. Use the latest image from the TomTom site to install the application. I installed mine on the SD card, but that's your option. I used this image (Control-click and save to desktop) to install and it worked great. It's up to you if you want to try that route. If I recall, it "knows" that Missing Sync handles the HotSync and places the app there for install. Once installed, I would use the same installer for maps (with the CD inserted). I installed Canada and the New England Maps. They do take quite a bit of time to install, but you only have to do it once. You cannot and should not uncompress the CAB files. I would try installing your primary map and go about the activation procedure. No sense waiting through two map installations if it's not going to find them.

    You can view/change your maps by going into Preferences > Right Arrow > Manage Maps.

    The one thing I found when installing TomTom was that the order of the process made a big difference.

  10. 10smom

    10smom New Member

    I am having same problem witt missing sync and tomtom

    I finally got the conduit onto missing sync now I cannot get it to sync on to treo. I put a sd card in. How do i get it to sync to SD card? Thanks for you help BTW I did use the above link to get the conduit on Missing sync. I called mark/space and they were much less then helpful saying that tomtom does not work with missing sync and they do not support it. They only want you to use their products it looks to me.
  11. cmeinck

    cmeinck Administrator

    Before you sync, click on the Install Tab in Missing Sync. I believe TomTom will "place" the file to be installed. Just drag it from Files to be installed on Handheld to Files to be placed on SD card.
  12. 10smom

    10smom New Member

    Voice command software on maps disk

    I finally got it on Treo after 4 days of trying. I am not sure what I did. I just kept doing same thing over again until it worked. I got the Southeast maps on sd card to. My question now is, I see there are voice commands to be installed on that map disk. am I suppose to install that too along with the maps? I did instiall some voice commed software on the application CD. Is that not enough? Does each map cd have their own voice command software?
  13. tomm

    tomm New Member

    Thanks Chris.

    I installed the program and only one map (Canada ON+QC+NB+NS+PE+NF (52mb) and it took about one hour, it' doing more than just copying, and the processor on the Powerbook ran 100% and the fan was going on all the time. It's insanity to spend this much time to install 52 mb map.
    (I also have Mapopolis Navigator and all the maps and one can just copy them to the SD card).

    This time I did get the activation screen, but I had to use the site, since the automatic acxtivation did not work - I do have GPRS enabled and use it all the time. I finally succeeded in activating this one map and it seems to be running with my iTrek bluetooth GPS unit. I'll take it for a drive now and will start learning it.

    So far, I am totally unimpressed and frustrated beyond belief and will probably ask for my money back.

    One important question:

    There are other Canadian maps and on Map CD1, there is 96 mb map of Canada.

    Will I have to go through this excruciating experience every time I want to install a new map? Will I have to activate every map? And can I now unstuff the CAB format maps using stuffit expander (or some other program?) and copy them to the appropriate location on the SD card using a card reader? This would be about million times faster and would actually be doable. Sitting there was 2 hrs to install a single map, watching it increment 1% every 5 minutes is no option, I just won't do it. What if I am travelling and want to add a map that I need?

    I have never seen anything so slow, why does it take so long? Why does this company insists on torturing their customers? Do they get some sadistic satisfaction from putting us throgh this purgatory? No matter how good this working product actually is, it's not worth the hassle.

    They actually know the installer on the CD does not work, but they won't include any note with the package to download it from the website.

    Finally, did you install the updater 5.201? Is it a good idea to install the update over this one?

  14. cmeinck

    cmeinck Administrator

    Same here. I used the site to activate my maps. When I did get the activation, I wrote it on a card that I keep in my wallet just to be on the safe side.

    The initial loading does take time, but you shouldn't have to continuously load maps. I haven't loaded maps since my initial install. At that time, I install New England and a Canadian map.

    The activation process is a bit of a hassle, but the real fun starts when you take it on the road. The app is great and you'll be impressed.

    I have not had a chance to update to 5.201. Things are working fine for me, so never had the urgent need to upgrade.

    I'm curious to hear your feedback once you've hit the road with it.

  15. tomm

    tomm New Member

    I am wondering about 2 points:

    1) if every newly installed map has to be activated - I'd find that unacceptable

    2) and once I get one map installed and activated via the agonizing USB (which is what I have now done), can I install other maps via the SD card reader - after unstuffing it with Stuffit expander or something else? I don't think it's practical/possible to install maps when you need them by waiting 1-3 hrs for it to finish, especially if you are travelling, etc.

    By the way, I have installed the 5.21 updater, , it crashed/reset my Treo when I launched the navigator, I had to re-enter the activation code and than it worked. I took it for a drive, to works to show me where I am on the map, but I now have to learn how to make a route, how to put it into the navigation mode, so I can see how well it will guide me.

    I will report my findings after my late night drive in the falling snow.

  16. cmeinck

    cmeinck Administrator

    How did you make out?
  17. tomm

    tomm New Member

    Finally I succeeded, but the hassle is not worth it. I think tomtom customer support sucks and I would actively discourage anyone from going through the pain. I think Mapopolis is good enough product without the hassle.

    Let me give you reader’s digest here, including advise for the fellow who had Missing Sync problems, than I'll ask you or anyone one question.

    Steps to take to succeed installing and activating tomtom Navigator 5 on the Mac (Tiger 10.4.3), using Missing Sync 5.02:

    1. Remove all tomtom software, including conduits you may have already installed on your mac or Treo
    2. Download the tomtom installer 1.04 from their website, they don't find it worthwhile to stick a piece of paper on the package to let a customer who just spent $200 on their software know that the installer on the CDs does NOT work.
    3. Insert the application CD and run the tomtom setup from the downloaded installer 1.04 and install the application and Sync to your Treo via the USB
    4. Install some map - US or Canadian (or tour regional map if you are in Europe) by inserting the map CD1 and again running the tomtom setup from the downloaded image,
    5. If you want to cut down time to 0.1% of the 100 hours it takes to install a single Map via USB (totally unacceptable waste of time), mount your USB card with a SD card reader on the desktop and when the tomtom setup ask you whether you want to install the map on Expansion or Other, click Other and than Navigate to your mounted card and click Select
    6. Put the card back into your Treo or wait 100 hrs to install a single Map via USB by syncing and now get ready for the activation hell,
    7. Click the Navigator on your treo, answer the questions, The Automatic activation via GPRS does NOT work - forget it. Click activate manually, Go to the activation website the program suggests, type in the product code and the code the treo will display and the website will give you Activation code, which you type in and with a bit of luck it will start a tour of the tomtom and you can choose your Bluetooth receiver and try it.
    8. If you want to install more Maps, use the SD card reader if you don't want to grow old and die while waiting for it to install another map. You will run into another BUG in the installer.
    I wanted to install another Canadian map and it told me it was on CD8, it than ejected CD1 and I inserted CD8 and it installed to map on the CD card again by clicking the Other button. However, after the installer installed one map, it shoed me that the other maps were on CD1, not on CD8. It than spits CD8, you install CD1 and it fives you error and stops, since the maps are on CD8 of course. But luckily now the installed again shows that the maps are on CD8, it spits out CD1 and you insert CD8 it installs the map correctly. So for every map you have to repeat the comedy or errors and finally you install all the maps you want in a few minutes, using the SD card reader. I did not experiment with some other way of getting around this installation bug with the CDs.

    Once installed, it seemed to work.

    9. I than ran the 5.21 updater using the tomtom setup from the image file and it installed the updated tomtotm navigator fine via USB.
    The first time I ran it on the Treo, it crashed and reset my Treo, I had to re-enter the Activation code again (the one from the website) and the new Navigator works reasonably well. It only reset itself once in 2 days.

    10. The end does NOT justify the means. I think I only did this to convince myself that it can be done, but I don't think it's reasonable to assume that user should go through such amount of pain. I support Apple computers for living and it drove me to desperation. I never, ever had so much trouble with Mapopolis software.

    One Question:

    I now have the large 92 mb Canadian map (from map CD1) and all the other, smaller Canadian maps from CD8 installed on my SD card, but there are many overlaps for Ontario - I think 3 or 4 maps contain Ontario. Does anyone know if there is always the same amount of detail for a particular city (Toronto) on all the maps that say Ontario or Canada? The way it's organized, I think the software does NOT load new maps as you may drive from one maps area to another one, otherwise it would not need so much overlap. That's one thing Mapopolis does seamlessly - switch from one map to another. I even drive across the Canadian US border and it finds the appropriate map and loads it all automatically. Chris - you may want to correct me here, but I don't think tomtom can do that??

  18. ragadelic

    ragadelic New Member


    I just wanted to thank you for taking the time to type up your detailed info. After HOURS of struggling it was a real life saver. I am very happy with my Tomtom Navigator however I am really fed up with companies that provide spotty or nonexistent support. Now if I can just figure out why I keep being told to "please hotsync first" when I try to upgrade to 5.2xx! Argh!
  19. TomTomHater

    TomTomHater New Member

    Good one! Yes, I agree that their customer service is beyone poopie. Come to think about it, the retailers should take it upon themselves to include this information, but then again if they did, maybe some people would just send it back. I never have found the 5.2 update... Mine says v 5.12 (5200) Any idea where it is?

  20. cmeinck

    cmeinck Administrator

    I'm not sure where you are with the install - or if you've given up yet. If not, I'd suggest downloading the software at the top of this thread. That version I know works well. I'd then delete all of the TomTom stuff that's on your Treo and start from scratch using the above installer. Install TomTom Navigator to your Treo -- and then install Maps to your SD Card. Use the web site for activation, do not use the Treo -- I had zero luck activating TomTom from the Treo. The biggest hassle I had with TT was the activation process. Once I got past that, the software is amazing. They need to do a better job with customer service and make it easier to install. Combating piracy is one thing -- but making it difficult on your paying customers is a whole other issue.

    Anyway, not guarantees...but this is what worked for me.

    Good luck. Let me know how it works out...