SD Card Help

Discussion in 'Treo Accessories' started by melmak, Nov 14, 2007.

  1. melmak

    melmak New Member

    Hello all I have a strange problem with a sd card. I bought two SanDisk 2GB cards to use in my Treo 700P. The first card I put in had no problems I could and write to the card with my Treo and also could copy files over from my XP machine to the card. The second card when I put it in I was able to read and write to it with the Treo but when I put it in a reader on my xp machine I could read the card but when I went to write to it I get a error saying the card is write protected. I have tried it on a number of computers using different SD card readers and it will not work. I finally got ahold of SanDisk and they had me RMA it. The problem now is the new one they sent me is doing the same thing. I can use Backup Buddy to do a back up to my card and Filz can read the card but when I put it in to write files to it from Windows it says that it is write protected. I can read the files on it in windows. I can not reformat it either in windows but I can from my Treo. Does anyone know if I am doing something wrong or could I have gotten another bad card from SanDisk. Thanks for any help you can give me with this. Melmak
     
  2. kdallen

    kdallen Moderator

    Absolutely not trying to insult your intelligence...have you flipped the little switch on the corner of the card which controls write-protect.
     
  3. melmak

    melmak New Member

    Hello Kdallen Yea that is the first thing I looked for on both of the cards. The first one I brought back to where I bought it and they tried that also. I thought for some reason when it was going into the reader it was catching on something but that is not the case. The new one I got today is doing the same thing. SanDisk sent me a new card after they got the old one back and tested it. Thanks anyway for your suggestion