Treo 650, Mac OS X, and movies

Discussion in 'Treo and Mac OS X' started by teislas, Jan 28, 2006.

  1. teislas

    teislas New Member


    I'm new to this forum and I'm learning a lot. I was interested in finding out how to watch movies on my Treo but it seems that the only software available to use for this is for PC. Is there any hope of a Mac user to watch movies on his/her Treo? Thanks.
  2. cmeinck

    cmeinck Administrator

    It's actually easier to watch movies on your Treo for Mac users. The first thing you'll need is TCPMP. This is the excellent freeware player that you'll need to install on your Treo. From there you'll need a codec for MPEG 4 files.

    The next step is to get the movies to your Treo. For this, you'll want to download Handbrake. If you insert a DVD, you'll be able to covert to an MPEG 4 file for use on your Treo.

    Here are my settings for Handbrake:
    Handbrake Settings:
    320x128 for widescreen DVD Settings
    320x240 for 4x3

    fps: 15
    Encoder: XviD
    Avg Bitrate kbps: 260
    2 pass encoding
    MPEG-4 Video/AAC Audio
    MP4 file
    Language None
    Language 1: English AC3 5ch
    Language 2: None
    Sample Rate: 4800
    Bitrate (kbps) 40

    Copy the file to your SD card, open up The Core Pocket Media Player and off you go.

  3. teislas

    teislas New Member

    Almost working

    Thanks so much for all your help. Everything's working except the audio. Before I play the movie, I get the error message:

    Player :MPEG4 AAC Audio decoder not included! It was removed from the official install package because of intellectual property considerations.

    No audio, just the video. The only choice is AAC for audio. What else can I do?

  4. cmeinck

    cmeinck Administrator

    You need the AAC codec in order to get audio. Check your PM.

  5. jeffreyfort

    jeffreyfort New Member

    Mac > Treo movies


    Could you revise the excellent instructions above so that there is a complete set of instructions how to do this? I probably would have the same ACC audio problem and I don't understand your "codec/ACC/PM" post.
  6. cmeinck

    cmeinck Administrator

    When you encode the movie as an MPEG 4, TCPMP requires a codec (plugin that allows audio) for AAC. Because of legal issues, TCPMP no longer distributes this codec. That being said, it can be found elsewhere on the internet via a little Google searching.

    With Handbrake, TCPMP and the AAC codec, you've got everything you need to watch movies.

    I'll do a more extensive writeup and how to.

  7. bsem650

    bsem650 New Member

    Watching itunes movies on treo 650

    I've been able to watch converted DVD on my treo 650, but would also like to buy TV shows and videos from itunes. Unfortunately the TCPMP player does not recogize the *.mv4 format. Any help out there?
  8. cmeinck

    cmeinck Administrator

    Those are copyright protected - similar to music purchased from iTunes. You'll only be able to use them on your iPod or Mac.

  9. ualreadyknow

    ualreadyknow New Member

    ERROR!!! Unknown file format

    I've followed the instruction for handbreak to the T, but my treo 650 keep giving me thi serror message. when i first installed tcpmp it worked fine, but then i unistalled it, because, i forgot, anyway, it won't play at all for .mp4 format. I dont understand, the movies when converted are fine, they play. I reinstalled, tcpmp, with all the plug-ins even the aac one. HELP, out of ideas.:wacko:
  10. cmeinck

    cmeinck Administrator

    I assume you mean they play through QuickTime?

    That's real odd. If you had a setup that worked, what has changed since then? Have you removed your SD card? Does TCPMP see the file?

  11. ualreadyknow

    ualreadyknow New Member

    ERROR!!! Unknown file format

    Yes they play fine in Quicktime. And yes TCPMP is able to see the file. I find it odd myslef, but I can't seem to find a reason nor a solution. I might of accidently removed my SD card, but evrythinh else works fine. I have even unistalled and reinstalled TCPMP to see if that would correct the issue. However, TCPMP will read .MPG files with no problem.
  12. nano

    nano New Member

    h264 support?

    How about playing apple MOV videos (m4v, mov) that are not protected (not from itunes store) and are encoded with h264 codec?

    In short, play none protected h264 videos. Possible?
  13. pstrjoe

    pstrjoe New Member

    Popcorn and Mactheripper

    I was wondering if anyone has used Mactheripper and Popcorn for their movie conversion. I understand that these might cost some money but if it was easier I think it might be worth it. Please let me know
  14. cmeinck

    cmeinck Administrator

    This is a great combo to make backups of your DVD's. With Handbrake, you dont' need either. Handbrake is one-stop shopping of sorts for converting video for use on your Treo.Wink

  15. pstrjoe

    pstrjoe New Member

    Getting the Movies Right

    Okay -- so I am able to play the movies on my Treo using Handbrake and TCPMP. The one thing I am confused about is the movie itself. I have tried to convert the Simpsons and Finding Nemo. Both do not have the full version of the movie in the file and Finding Nemo has deleated scenes in the middle of the movie!!!! I followed everything at the beginning of this Thread. Any Suggestions??!?!


  16. bodieq

    bodieq New Member


    I have gone over these directions several times, but I am still not able to find an AAC codec that will work with my Mac so that I can watch movies with TCPMP. I have done many searches for AAC Codec, but have only found stuff that is PC based. I really appreciate your input thus far, but I still do not know what an AAC Codec is, where to find it, and what to do with it if I do! I will keep searching, but if you could direct me, that would be awesome.

  17. cmeinck

    cmeinck Administrator

  18. bodieq

    bodieq New Member


    Thanks so much! I appreciate the quick reply.

  19. wchau

    wchau New Member

    Hi Chris,

    The list of Audio sample rate (Hz) in my HandBrake UI is 22050, 24000, 44100, and 48000. There is no 4800 as you mentioned.

    Please advise!

  20. cmeinck

    cmeinck Administrator

    It's 48000.