SD Card doesnt read any sd cards

Discussion in 'Treo 680' started by Stenneke, Jul 2, 2009.

  1. Stenneke

    Stenneke New Member

    Hi,

    I have a problem. My palm treo 680 card slot doesnt work any more. If i put a sd card in it (it doesnt matter which one) it `s says unrecognized format and ask me to format it. I don`t want that so I don`t do that. When i put a empty but formatted card in the slot, it says the same thing. When i answer to format it it will say that the palm cannot format it because it`s an unrecognized card. Help me, because my palm is now unusable. I tried 4 different sd cards and it still says the same thing. Hard resets dont help. Has somebody an idea?

    Edwin
     
  2. Pilot135pd

    Pilot135pd New Member

    At the beginning of your question you said that it says unrecognized format a asks you to format it BUT YOU DON'T WANT THAT. Then I don't understand what you're asking here. Just click yes when it asks that and you're done.
     
  3. bmeador

    bmeador New Member

    had the same problem with my 650....

    ....and it turned out that it would not "see" the new HD SD cards. if I use an older 2 gig or smaller non "HD" card, it worked fine. The minute I tried 4 gig HD cards, the slot would not read them.

    That could be your issue, too.